If you don't find an answer, please click here to post your question.
Reply
Highlighted
Occasional Advisor
Posts: 9
Registered: ‎02-15-2018

Select To Unmute - How Do I Remove This?

On our website, when the video first loads, it is on mute and a little caption says "Select To Unmute". In the top left corner, there is a sound icon which can be clicked to unmute it. How do we make the volume on by default? So the user doesn't have to click anything, the volume should just be on by default. 

Ooyalan
Posts: 41
Registered: ‎10-06-2014

Re: Select To Unmute - How Do I Remove This?

Hello vidone,

I'd need a bit more information to troubleshoot this (url and platforms where this is happening), but here are some things you may want to check:

-Are you using autoplay? There are some platforms that mute videos on autoplay and require user interaction to unmute, with no way around it.

-Give an eye to your code and see if the 'InitialVolume' player parameter is being used (and set to 0), this could be what you need to get rid of.

Here's more info about such parameter: http://help.ooyala.com/video-platform/api/pbv4_api_embedparams.html#pbv4_api_embedparams__initialVol...

Hope this helps,
Ana
Occasional Advisor
Posts: 9
Registered: ‎02-15-2018

Re: Select To Unmute - How Do I Remove This?

Hi Ana,

 

I PM'd you the additional details you requested. Can you please take a look and respond? Thanks.

Ooyalan
Posts: 41
Registered: ‎10-06-2014

Re: Select To Unmute - How Do I Remove This?

Hi vidone,

 

So yeah, this is the first scenario I suspected. Apple started blocking unmuted autoplay of videos on Safari since its version 11 for desktop browser and that's the reason why you see such message (a workaround to autoplay it muted, instead of not autoplaying it at all)

 

Notification Autoplay for Safari 11: http://community.ooyala.com/t5/Information-News/Notification-Autoplay-for-Safari-11/m-p/9887#M168

 

There's a workaround to use script to add a pop-up message asking viewers to add your site to the allowed list for unmuted autoplay. Here's an example: http://community.ooyala.com/t5/Ooyala-Player-Knowledge-Base/Autoplay-for-Safari-11-Script-Example/ta...

 

Being this a browser limitation, there's not much the player can do about it, the above would represent a best effort.

 

Please give it a try, may work for you.

 

Ana

Occasional Advisor
Posts: 9
Registered: ‎02-15-2018

Re: Select To Unmute - How Do I Remove This?

Hi Ana,

 

I have two quick follow-up questions:

 

1. How can we turn off autoplay specifically for Safari only?

 

2. How come the "Select To Unmute" is also happening in FireFox? I understand your explanation for why it is happening in Safari. But why is it happening in FireFox? One of our competitors that also uses Ooyala doesn't have this issue at all in FireFox, but we do. (PM'd you URL just now...)

Ooyalan
Posts: 41
Registered: ‎10-06-2014

Re: Select To Unmute - How Do I Remove This?

Hello!

 

About your queries:

 

1. How can we turn off autoplay specifically for Safari only?

-This can't be done out of the box, you'd need to implement a logic in your site that evaluates the user agent and sets the autoplay parameter based on that.

 

2. How come the "Select To Unmute" is also happening in FireFox? 

-This should not happen in Firefox, I tested on my side and wasn't able to reproduce the issue, didn't get the 'Select to Unmute' message on either URLs. Tested in Firefox 58.0.2, did you see this in any other version? 

 

If you'd like us to take a deeper look at your particular URL, it's better to open a support ticket.

 

Hope this helps,

Ana