If you don't find an answer, please click here to post your question.
Reply
Highlighted
Ooyalan
Posts: 4
Registered: ‎01-18-2017

How to force the Ooyala Player V4 prefer HTML5 over Flash

[ Edited ]

Due to HTML5 standards not allowing mixing protocols (sites running on HTTPS cannot play video streams served over HTTP), we could not roll out V4 with HTML5 as default without breaking many customers who still mix HTTPS sites with HTTP content streams. As a result, we need to allow our customers the ability to opt-in to prefer HTML5 playback, using a page-level parameter. (Google provides a good guide to identifying mixed content here)

 

The way for users to opt-in as ready for HTML5-first is as follows:

 

 

We will make V4 default to prioritize HTML5 playback as soon as possible, but only when it’s safe to do so for our broad customer-base.

 

Ooyalan
Posts: 4
Registered: ‎01-18-2017

Re: How to force the Ooyala Player V4 prefer HTML5 over Flash

Note that starting with Player version 4.13.4, HTML5 is the default priority for video playback. Therefore, the page-level parameter is no longer needed starting with that version (unless you now want to use it to force Flash to be preferred)