If you don't find an answer, please click here to post your question.
Reply
Occasional Advisor
Posts: 9
Registered: ‎04-13-2017

ooyala v4 hosting resources not working on windows safari and Internet explorer

[ Edited ]

Hi,

 

I included the following resources into my project,

<!-- V4 JS core is required. Plugins such as skin, discovery and Advertising need to be loaded separately -->
<script src="https://player.ooyala.com/static/v4/production/latest/core.min.js"></script>

<!-- Change these html5-skin.min.css and html5-skin.js to your local build if necessary -->
<script src="https://player.ooyala.com/static/v4/production/latest/video-plugin/main_html5.min.js"></script>
<link rel="stylesheet" href="https://player.ooyala.com/static/v4/production/latest/skin-plugin/html5-skin.min.css"/>

<script src="https://player.ooyala.com/static/v4/stable/latest/video-plugin/bit_wrapper.min.js"></script>
<script src="https://player.ooyala.com/static/v4/production/latest/skin-plugin/html5-skin.js"></script>
<script src="https://player.ooyala.com/static/v4/stable/latest/other-plugin/discovery_api.min.js"></script>

 

but the issues is, these latest resources are not at all working in safari and internet explorer, it remains blank. But these are working as expected in chrome and firefox.

can you please help me here.

NOTE: I even tried rearranging the order but still no use.

Thanks In Advance

Ooyalan
Posts: 29
Registered: ‎07-11-2016

Re: ooyala v4 hosting resources not working on windows safari and Internet explorer

Hi,

I tried to reproduce this issue on my side but I was able to load the player using Safari and IE 

Take a look at my example:

<script src="//player.ooyala.com/static/v4/production/latest/core.min.js"></script>
<script src="//player.ooyala.com/static/v4/production/latest/video-plugin/main_html5.min.js"></script>
<script src="//player.ooyala.com/static/v4/production/latest/video-plugin/bit_wrapper.min.js"></script>
<script src="//player.ooyala.com/static/v4/production/latest/skin-plugin/html5-skin.min.js"></script>
<script src="//player.ooyala.com/static/v4/production/latest/other-plugin/discovery_api.min.js"></script>
<link rel="stylesheet" href="//player.ooyala.com/static/v4/production/latest/skin-plugin/html5-skin.min.css" />

Highlighted
Senior Member
Posts: 4
Registered: ‎12-19-2017

Re: ooyala v4 hosting resources not working on windows safari and Internet explorer

I have quite similar question. Video doesn't play in IE11 on WIn7 (on Win10 works fine) with self-hosting bit_wrapper.js file. Somehow, it works, when I specify external src. Like this:

<script src="//player.ooyala.com/static/v4/production/latest/video-plugin/bit_wrapper.min.js"></script>

Content of remote file and my local file is completely identical. I am not sure what am i doing wrong. Is there anything that I should configure additionally?