Reply
Highlighted
Visitor
Posts: 3
Registered: ‎12-20-2016
Accepted Solution

TVOS linker error while creting IPA

HI 

 

I have integrated the  Ooyala Pulse tvOS Framework 2.x for ad support , the app works fine if i am installing through xcode . If i am trying to make a IPA  it gives a linker error like below .

 

it does not show any error

 

All DICompileUnits must be listed in llvm.dbg.cu

LLVM ERROR: Broken module found, compilation aborted!

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

can some one  please help me on this 

 

Thanks

Subhasis


Accepted Solutions
Ooyalan
Posts: 26
Registered: ‎11-08-2016

Re: TVOS linker error while creting IPA

Hello Subhasis83,

 

I have attached a Pulse Framework to this thread, added it to your tvOS app, this should solve the problem.

Let us know if it worked for you,

 

Regards,

Ooyala Technical Support

View solution in original post

Attachment

All Replies
Ooyalan
Posts: 26
Registered: ‎11-08-2016

Re: TVOS linker error while creting IPA

Hello,

Thank you for posting, what version of Xcode and tvOS are you currenlty using? Our engineering team is working on a smiliar issue but I would like to confirm that it is for the same version that you are using.

 

Thank you, regards.

Paulo Padilla

Technical Support Engineer

Visitor
Posts: 3
Registered: ‎12-20-2016

Re: TVOS linker error while creting IPA

Hi Paulo,

 

My current  versions for xcode and Tvos are

 

Xcode :-  Version 8.0 (8A218a)

TVOS:-    tvos 10.0

 

Please let me know if you need any other info

 

Thanks

Subhasis

Ooyalan
Posts: 26
Registered: ‎11-08-2016

Re: TVOS linker error while creting IPA

Hi,

 

Our engineering team found a similar issue that the one you meniton and currently working on a general fix. I am sharing with you a newer Pulse SDK attached on this thread, please try using it and let us know if your problem is solved.

 

Best regards,

Paulo Padilla

Technical Support Engineer

Attachment
Visitor
Posts: 3
Registered: ‎12-20-2016

Re: TVOS linker error while creting IPA

Hi

 

I could able to make the IPA from the framework provided by you  , but the build is not launching in device  .

 

if i try to load through xcode it gives a error like below 

dyld: Library not loaded: @rpath/Pulse.framework/Pulse

 

i have provided  the correct framework path in build settings

The newframework does not work for simulator also.

Please let me know your suggestions on this 

 

Thanks

Subhasis

Ooyalan
Posts: 26
Registered: ‎11-08-2016

Re: TVOS linker error while creting IPA

Hello Subhasis83,

 

I have attached a Pulse Framework to this thread, added it to your tvOS app, this should solve the problem.

Let us know if it worked for you,

 

Regards,

Ooyala Technical Support

Attachment